You are currently using an old version of Shared Contacts for Gmail